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NOTE: All the available material is compiled from the Internet Explorer Browser’s 

Help. 

Introducing the Internet Explorer Web browser 

Internet Explorer makes it easier to get the most from the World Wide Web, whether you are searching for 

new information or browsing your favorite Web sites. And built-in IntelliSense technology can save you 

time completing routine Web tasks, such as automatically completing Web addresses and forms for you, 

and automatically detecting your network and connection status. 

Browser Interface 

To run the Internet Explorer browser, press Start button, Programs list then Internet Explorer item. 

Alternatively, you can access the Internet Explorer through its icon on the Task Bar. 

 
Or you can access it through the generated Internet Explorer shortcut icon on the Desktop area.  

 

The browser consists of the following components: 

Title Bar: this bar includes the Internet Explorer title and the title of the currently displayed web page. 

 
Main Menu: this menu includes the list of useful commands to use. 

 
Toolbar: a set of useful buttons that enable you to go one page forward, or backward, to stop the web page 

loading process, to refresh the current page, to display the home page of your browser, and more. 

 

 

 

To return to the last page you viewed, click the Back button on the toolbar. 

 

To view one of the last nine pages you visited in this session, click the arrow to the side of the 

Back or Forward button, and then click the page you want from the list. 

 

To stop a page while downloading, press the Stop button. 

 

If you wish to reload a page – in case it did not load completely or some of the images 

were not loaded properly – you can press the Refresh button. 

 

If there is one page you visit most, you can make it your home page so that it is displayed every 

time you start Internet Explorer or click the Home button on the toolbar. 

 

You can search for Web sites by clicking the Search button on the toolbar. Then in the Search 

bar, type a word or phrase that describes what you're looking for. When your search results 

appear, you can view the individual Web pages without losing your list of search results. 
 

After you have added a Web page to your list of favorite pages, any time you want to open that 

page, just click the Favorites button on the toolbar, and then click the shortcut in the Favorites 

list. 
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Browse through a list of Web pages you recently visited by clicking the History button the 

toolbar. On the toolbar, click the History button. The History bar appears, containing links for 

Web sites and pages visited in previous days and weeks. In the History bar, click a week or 

day, click a Web site folder to display individual pages, and then click the page icon to display 

the Web page. To sort or search the History bar, click the arrow next to the View button at the 

top of the History bar. 

 

Address Bar: this bar displays the address of the current web page. Through this bar, you can type in the 

address of the page you wish to view. 

  
 Next comes the area where is displayed. If the page exceeds the screen size, you can notice a horizontal 

scroll bar and a vertical scroll bar to enable scrolling along the web page. 

The easiest way to get around the Web 

 When you start typing a frequently used Web address in the Address bar, a list of similar 

addresses appears that you can choose from. And if a Web-page address is wrong, Internet 

Explorer can search for similar addresses to try to find a match.  

 You can also search directly from the Address bar. Just type common names or words, and 

Internet Explorer can automatically take you to the site that most likely matches what you are 

searching for, and list other likely sites as well.  

 Go to other Web pages similar to the one you are viewing, without even doing a search. Just use 

the Show Related Sites feature.  

 Once you're on a Web page, Internet Explorer can help you complete entries in any kind of Web-

based form. Start typing, and a list of similar entries appears that you can choose from.  

 Listen to broadcast and Internet-only radio stations while you browse. Choose from a wide variety 

of music and talk radio stations, and add them to your Favorites list. The radio toolbar is available 

in Internet Explorer when you install Windows Media Player.  

Finding the information you want  

You can find information on the Web in a variety of ways.  

 Click the Search button on the toolbar to gain access to a number of search providers. Type a 

word or phrase in the Search box.  

 Type go, find, or ? followed by a word or phrase in the Address bar. Internet Explorer starts a 

search using its predetermined search provider.  

 After you go to a Web page, you can search for specific text on that page by clicking the Edit 

menu and then clicking Find (on this page).  

 Note: If a Web address doesn't work, Internet Explorer asks if you want to search for similar Web 

addresses. You can change this setting so that Internet Explorer searches automatically without 

prompting.  

To change your home page 

Your home page is the page that is displayed every time you open Internet Explorer. Make sure it is a page 

that you want to view frequently. Or make it one that you can customize to get quick access to all the 

information you want, such as the www.aucegypt.edu home page.  

1. Go to the page you want to appear when you first start Internet Explorer.  

2. On the Tools menu, click Internet Options.  

3. Click the General tab.  

4. In the Home page area, click Use Current.  

http://www.aucegypt.edu/
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Tip:  To restore your original home page, click Use Default.  

To print a Web page 

1. On the File menu, click Print.  

2. Set the printing options you want.  

3. To print a frame or item in a Web page, right-click the frame or item, and then click Print or Print 

Frame.  

Sharing bookmarks and favorites  

Favorites, known as bookmarks in Netscape Navigator, are a convenient way to organize and link to Web 

pages that you visit frequently.  

Internet Explorer automatically imports all your Netscape bookmarks. On the Favorites menu, click the 

Imported Bookmarks folder to view them. 

If you use Internet Explorer on several computers, you can easily share favorites between computers by 

importing them. Also, if you use both Internet Explorer and Navigator, you can keep your favorites and 

bookmarks up-to-date with each other by importing them between programs.  

 To import bookmarks or favorites, click the File menu, and then click Import and Export.  

 To export favorites to bookmarks or favorites on the same or another computer, click the File 

menu, and then click Import and Export.  

 Exported favorites are saved as a regular HTML file, so either Internet Explorer or Navigator can 

import them. You can export a selected folder in your Favorites list, or all of your favorites.  

 

To enter Web information more easily 

The AutoComplete feature saves previous entries you've made for Web addresses, forms, and passwords. 

Then, when you type information in one of these fields, AutoComplete suggests possible matches. These 

matches can include folder and program names you type in the Address bar, and search queries, or 

information for just about any other field you fill in on a Web page.  

1. In the Address bar, in a field on a Web page, or in a box for a username or password, start typing 

the information. If you've typed a similar entry before, AutoComplete lists possible matches as 

you type.  

2. If a suggestion in the list matches what you want to enter in that field, click the suggestion. If not, 

continue typing.  

3. When typing information in Web 

forms, and typing passwords, you can 

remove an item from the list of suggestions 

by clicking the item and then pressing the 

DELETE key.  

 To adjust AutoComplete settings 

You can tailor the AutoComplete feature to save 

and suggest only the information you want. You 

can choose whether to use AutoComplete for 

Web addresses, forms, and passwords, or not use 
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it all. And you can clear the history for any of these.  

1. On the Tools menu in Internet Explorer, click Internet Options.  

2. Click the Content tab.  

3. In the Personal information area, click AutoComplete.  

4. Select the check boxes for the AutoComplete options you want to use.  

Making pages available for offline viewing 

When you make a Web page available offline, you can read its content when your computer is not 

connected to the Internet. For example, you can view Web pages on your laptop computer when you don't 

have a network or Internet connection. Or you might want to read Web pages at home but do not want to tie 

up a phone line.  

You can specify how much content you want available, such as just a page or a page and its entire links, 

and choose how you want to update that content on your computer. 

If you just want to view a Web page offline, and you don't need to update the content, you can save the 

page on your computer. There are several ways you can save the Web page, from just saving the text, to 

saving all of the images and text needed to display that page as it appears on the Web.  

To make the current Web page available offline 

1. On the Favorites menu, click Add to Favorites.  

2. Select the Make available offline check box. 

 
3. To specify a schedule for updating the page, and how much content to download, click Customize.  

4. Follow the instructions on your screen.  

Note: Before you go offline, make sure you have the latest version of your pages by clicking the Tools 

menu and then clicking Synchronize.  

To save a Web page on your computer 

1. On the File menu, click 

Save As.  

2. Double-click the folder you 

want to save the page in.  

3. In the File name box, type a 

name for the page.  

4. In the Save as type box, 

select a file type.  

To save all of the files needed to display 

this page, including graphics, frames, and 
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style sheets, click Web Page, complete. This option saves each file in its original format.  

To save just the current HTML page, click Web Page, HTML only. This option saves the information on 

the Web page, but it does not save the graphics, sounds, or other files. 

To save just the text from the current Web page, click Text Only. This option saves the information on the 

Web page in straight text format. 

Saving pictures or text from a Web page 

As you view pages on the Web, you’ll find information that you'd like to save for future reference or share 

with other people. You can save the entire Web page or any part of it: text, graphics, or links.  

1. To save a page or picture without opening it, right-click the link for the item you want, and then 

click Save Target As. 

2. To copy information from a Web page into a document, select the information you want to copy, 

click the Edit menu, and then click Copy. 

3. To create a desktop shortcut to the current page, right-click in the page, and then click Create 

Shortcut. 

4. To use a Web page image as desktop wallpaper, right-click the image on the Web page, and then 

click Set as Wallpaper. 

 

To turn off graphics to display all Web pages faster 

1. On the Tools menu in Internet 

Explorer, click Internet Options.  

2. Click the Advanced tab.  

3. In the Multimedia area, clear one 

or more of the Show pictures, Play 

animations, Play videos, or Play sounds 

check boxes.  

Tips 

 If the Show pictures or Play 

videos check box is cleared, you can still 

display an individual picture or animation 

on a Web page by right-clicking its icon 

and then clicking Show Picture.  

 If the pictures on the current page 

are still visible after you clear the Show 

pictures check box, you can hide them by 

clicking the View menu and then clicking 

Refresh.  

To send a Web page in e-mail  

 Click the File menu, point to Send, and then click Page By E-mail or Link By E-mail. Complete 

the mail message window, and then send the message. Note that you must have an e-mail account 

and an e-mail program set up on your computer.  
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Protecting your identity over the Internet 

You can use a personal certificate to protect your identity over the Internet. A certificate is a statement 

guaranteeing the identity of a person or the security of a Web site. You can control the use of your own 

identity by having the private key that only you know on your own system. When used with mail programs, 

security certificates with private keys are also known as "digital IDs." 

Internet Explorer uses two different types of certificates: 

 A "personal certificate" is a kind of guarantee that you are who you say you are. This information 

is used when you send personal information over the Internet to a Web site that requires a 

certificate verifying your identity.  

 A "Web site certificate" states that a specific Web site is secure and genuine. It ensures that no 

other Web site can assume the identity of the original secure site.  

How do security certificates work? 

A security certificate, whether it is a personal certificate or a Web site certificate, associates an identity 

with a "public key". Only the owner knows the corresponding "private key" that allows the owner to 

"decrypt" or make a "digital signature." When you send your certificate to other people, you are actually 

giving them your public key, so they can send you encrypted information, which only you can decrypt and 

read with your private key. 

The digital signature component of a security certificate is your electronic identity card. The digital 

signature tells the recipient that the information actually came from you and has not been forged or 

tampered with. 

Before you can start sending encrypted or digitally signed information, you must obtain a certificate and set 

up Internet Explorer to use it. When you visit a secure Web site (one that starts with "https"), the site 

automatically sends you their certificate. 

Where do you get your own security certificates? 

Security certificates are issued by independent certification authorities. There are different classes of 

security certificates, each one providing a different level of credibility. You can obtain your personal 

security certificate from certification authorities. 

Securely sharing personal information 

Profile Assistant can save you from having to enter the same information repeatedly, such as your address 

or e-mail name, every time you visit a new Web site that requests such information. It does this by storing 

the information on your computer. None of this information can be viewed on your computer, or shared 

with others, without your permission.  

When a Web site requests information from Profile Assistant, the request will tell you: 

 The Internet address of the site requesting the information.  

 What information the site is requesting from Profile Assistant, so you can exclude information if 

you want.  

 How this information will be used.  

 Whether this site has a secure connection (Secure Sockets Layer or SSL). If it does, you can verify 

the site's certificate.  
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You can encrypt your personal information, both when it is transmitted and when it is stored on your 

computer. 

What you need to know about cookies 

Some Web sites store information in a small 

text file, called a "cookie," on your hard disk. 

Cookies contain information about you and 

your preferences. For example, if you inquire 

about a flight schedule at an airline's Web site, 

the site might create a cookie that contains 

your itinerary. Or it might only contain a 

record of which pages within the site you 

visited, to help the site customize the view for 

you the next time you visit.  

Only the information that you provide, or the 

choices you make while visiting a Web site, 

can be stored in a cookie. For example, the 

site cannot determine your e-mail name unless 

you choose to type it. Allowing a Web site to 

create a cookie does not give that or any other 

site access to the rest of your computer, and 

only the site that created the cookie can read 

it. 

Internet Explorer is set up to allow the creation of cookies; however, you can specify that you be prompted 

before a site puts a cookie on your hard disk, so you can choose to allow or disallow the cookie; or you can 

prevent Internet Explorer from accepting any cookies.  

You can specify different settings for different security zones. For example, you might want to allow Web 

sites to create cookies if they are in your Trusted sites or Local intranet zone, prompt you before creating 

cookies if they are in your Internet zone, and never allow cookies if they are in your Restricted sites zone.  

Using Content Advisor to control 

access 

The Internet provides us with 

unprecedented access to a wide variety of 

information. Some information, however, 

may not be suited for every viewer. For 

example, you might want to prevent your 

children from seeing Web sites that 

contain violent or sexual content.  

With Content Advisor, Internet Explorer 

provides a way to help you control the 

types of content that your computer can 

gain access to on the Internet. After you 

turn on Content Advisor, only rated 

content that meets or exceeds your criteria 
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can be displayed. You can adjust the settings. 

With Content Advisor, you can: 

 Control access to Content Advisor settings. You turn Content Advisor on, and view the settings, 

by setting up a password. You will need this password to change any Content Advisor settings, so 

you might want to write it down for future reference.  

 View and adjust the ratings settings to reflect what you think is appropriate content in each of four 

areas: language, nudity, sex, and violence.  

 Adjust what types of content other people can view with or without your permission. You can 

override content settings on a case-by-case basis.  

 Set up a list of Web sites that other people can never view, regardless of how the sites’ contents 

are rated.  

 Set up a list of Web sites that other people can always view, regardless of how the sites’ contents 

are rated.  

 View and change the ratings systems and bureaus you use.  

Content Advisor is set to the most conservative (least likely to offend) settings when you first turn it on. 

You can adjust these settings to match your own preferences. 

Not all Internet content is rated. If you choose to allow other people to view non-rated sites on your 

computer, some of those sites could contain inappropriate material. 

Changing fonts and background colors 

When Web authors and designers create Web pages, they often specify particular font colors and sizes, 

typefaces, and background colors. These settings are specified for each item, or in a "style sheet," which is 

a type of template for specifying how different styles should appear throughout a Web page or site. 

You can override any or all of these settings, which is useful if you have limited or low vision. You can 

specify your font and color preferences for all pages that do not use style sheets, and then you can specify 

whether to use any or all of your preferences on pages that use style sheets. 

To correctly display Web pages encoded in any language 

Most Web pages contain information that tells the browser what language encoding (the language and 

character set) to use.  

If the page does not include that information, and you have the Language Encoding Auto-Select 

feature on, Internet Explorer can usually determine the appropriate language encoding.  

To turn Auto-Select on 

On the View menu in Internet Explorer, point to Encoding, and then make sure Auto-Select has a 

check mark. If it doesn't, click it. If you are prompted to download language support components, click 

Download. If Auto-Select cannot determine the correct language encoding, and you know what 

language encoding it should be, you can manually select it. 

To select the language encoding for a Web page 

If your Web browsing takes you to sites written in numerous languages, Internet Explorer can update 

your computer with the character sets you need to view these sites correctly. On the View menu, point 
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to Encoding, point to More, and then click the appropriate language. If you are prompted to download 

language support components, click Download.  

Note: If the Auto-Select feature or a specific language pack is not installed on your computer, Internet 

Explorer will prompt you to download the files as needed.  


