Adobe Dreamweaver CS4

Prepared by
Heba Amer
Fall 2011
# Table of Contents

Introduction .................................................................................................................. 1
Defining a Local Site ...................................................................................................... 1
Dreamweaver Environment .......................................................................................... 5
Creating Site Pages ...................................................................................................... 5
Work Area .................................................................................................................... 6
Page Properties .......................................................................................................... 7
Defining the Document Page title ............................................................................ 7
Saving ........................................................................................................................... 8
Images ........................................................................................................................... 8
Setting Image Properties ........................................................................................... 9
Tables ........................................................................................................................... 9
Linking to other pages ................................................................................................ 10
Linking to other files .................................................................................................. 10
Link to e-mail .............................................................................................................. 11
Link to presentations .................................................................................................. 11
Inserting Media in the site ............................................................................................ 11
Working with templates .............................................................................................. 12
Uploading the site to a server ..................................................................................... 14
Useful links .................................................................................................................. 15
# Table of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Create New Site</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Create New Site From Menu</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>Site Definition Dialog</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>Site Definition 2</td>
<td>3</td>
</tr>
<tr>
<td>5</td>
<td>Site Definition 3</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>Site Definition 4</td>
<td>4</td>
</tr>
<tr>
<td>7</td>
<td>Site Definition 5</td>
<td>4</td>
</tr>
<tr>
<td>8</td>
<td>Dreamweaver Environment</td>
<td>5</td>
</tr>
<tr>
<td>9</td>
<td>New Document Dialog</td>
<td>6</td>
</tr>
<tr>
<td>10</td>
<td>Dreamweaver Code and Design View</td>
<td>6</td>
</tr>
<tr>
<td>11</td>
<td>Dreamweaver Properties Tab Group</td>
<td>7</td>
</tr>
<tr>
<td>12</td>
<td>Page Properties Dialog</td>
<td>7</td>
</tr>
<tr>
<td>13</td>
<td>Change Page Title</td>
<td>8</td>
</tr>
<tr>
<td>14</td>
<td>Image Tag Dialog</td>
<td>9</td>
</tr>
<tr>
<td>15</td>
<td>Image Properties</td>
<td>9</td>
</tr>
<tr>
<td>16</td>
<td>Insert Table</td>
<td>10</td>
</tr>
<tr>
<td>17</td>
<td>Text properties</td>
<td>10</td>
</tr>
<tr>
<td>18</td>
<td>Insert Email Link</td>
<td>11</td>
</tr>
<tr>
<td>19</td>
<td>Insert Plugin</td>
<td>12</td>
</tr>
<tr>
<td>20</td>
<td>Save As Template Dialog</td>
<td>13</td>
</tr>
<tr>
<td>21</td>
<td>Update Template files</td>
<td>13</td>
</tr>
<tr>
<td>22</td>
<td>Manage Sites</td>
<td>14</td>
</tr>
<tr>
<td>23</td>
<td>Set FTP settings</td>
<td>15</td>
</tr>
<tr>
<td>24</td>
<td>Get and Put</td>
<td>15</td>
</tr>
</tbody>
</table>
Introduction
To use Dreamweaver to create a website, you should

- Have a design in mind about the main outline of the site.
- Develop the site locally and test it
- Upload (put) the site on an internet server

The first step is totally user dependent. It is determined by what you want to present in the site; the menus used, images presented and links to other sites. After you have this in mind, you can go to the next step.

To start developing the site, create a folder on your local machine where you will keep all the files related to this site. It is very important to create this root folder of the site and deal with the site pages from within Dreamweaver and not as individual files. Such a behavior will limit having broken links in the site pages to a minimum, as Dreamweaver keeps track of the references used among pages, images and other files.

In this document, we will create a root folder on “D:DW Training Course\” to keep our site in. Inside this folder, we will have an images folder to keep the images used in the site and a pdf folder to keep the documents. Now let’s go step by step to create the site and handle the pages.

Defining a Local Site
From the first screen, click on “Create New Dreamweaver Site…”

![Create New Site](image)

Or, from the menu, click on “Site > New Site…” as in Figure 2
The following dialog then appears:

![Site Definition Dialog](image)

**Figure 3 - Site Definition Dialog**

Fill in the information for site name, for example “DW Training Course”. If your site will be hosted on a server, fill in the URL address for it. Then click on Next.
If the site will not use server technology, leave the default option i.e. the No. Then click Next.

Enter the location of the root folder on the local machine. If you browse to select the folder, make sure that the right folder is selected in the text box.

The next step in the wizard asks about the connection to the server. Usually you would upload your site using ftp connection. For now as we are working locally, select “None” from the drop down menu.
Next, a site definition summary window shows. Review the summary then click on DONE.

Having done so, the following screen appears
Figure 8 - Dreamweaver Environment

Dreamweaver Environment

Figure 8 shows the environment of Dreamweaver after creating a site. On the top, there are the menus to handle the site. On the right, there are multiple windows to use, like the Files and Assets window and CSS Styles window. If the Files and Assets window does not appear, you can go to the upper menu, click on Window, then choose Files, or simply press F8.

At the bottom part you can find the properties window, which is empty in Figure 8 as no files are open. The properties window shows different items according to what is selected in the work area. For example, if an image is selected, the properties window will show the image properties; width, height, etc. If text is selected, it will show the text properties; font, size, etc. If nothing is selected, it shows the current page properties.

Creating Site Pages

A web site is usually a collection of html pages. To start adding pages to the site, click on Create New HTML. Or Click on the File menu and select New. The following dialog opens:
From the first column, select *Blank Page*. From the second column *Page Type* select *HTML* and from the third column *Layout* select *<none>*. Click *Create* button to create the blank page.

**Work Area**

The created document can be viewed in many ways. The *Code* view is preferred by programmers where they can enter html tags. The *Design* view shows a sample of how the page will look on the
browser. The *Split* view, shown in Figure 10, shows both the code and design parts. So if you edit in the design area, you can see the generated html code in the code area reflecting your edits.

![Figure 11 - Dreamweaver Properties Tab Group](image)

**Page Properties**

To set the properties for a page, click on *Page Properties* on the *Properties Tab* shown in Figure 11. This will launch the following dialog box (Figure 12)

![Figure 12 - Page Properties Dialog](image)

From this dialog, the user can set many properties such as the different fonts and their sizes used for the page, the page colors and background images if needed as well as set the margin sizes.

**Defining the Document Page title**

Though the document has a name, it is still labeled *Untitled Document*; that is because it needs an HTML document name, or page title. Defining a page title helps site visitors identify the page they
are browsing: the page title appears in the browser title bar. To set the page title, open the Page Properties dialog box (as shown in Figure 12). Select the Title/Encoding. In the Title field, enter the name of the page. Click on Apply or OK.

![Page Properties dialog box](image)

**Figure 13 - Change Page Title**

**Saving**

To save this page, click on File then Save. The Save As dialog opens with the root folder selected in the Save in drop down menu. In the File Name field, type (documentname).html. Next, click on Save.

Notice that the document name will now appear in the top of the document window.

**Images**

To insert an image into the document, go to the insertion point and select Image from the Insert menu. Select the image from the browse dialog and click on OK. Then the following dialog appears (as shown in Figure 14). The alternate text is the text that will appear when the mouse hovers over the image. It also appears in the image’s place on the page if the image takes a long time to load.
Setting Image Properties

Note that the properties tab now shows the properties of the image, as the image is selected in the page (Figure 15)

![Image Tag Accessibility Attributes](image.png)

Figure 14 - Image Tag Dialog

The fields \( W \) and \( H \) refer to the image’s width and height respectively. These values are in pixels. The \( Src \) field has the relative path or the location of the image file. The field \( Link \) can include a URL if the image is to be used to link to another page or file. An image map is an image that has been divided into regions, or "hotspots"; when a user clicks a hotspot, an action occurs (for example, a new file opens). \( Align \) is used to align the text and image according to how the user sees fit. \( Border \) sets the width in pixels of a border of the image. \( V\ Space \) and \( H\ Space \) add space in pixels, along the sides of the image. \( V\ Space \) adds space along the top and bottom of an image. \( H\ Space \) adds space along the left and right of the image.

Tables

To insert a table on the webpage, click on Insert then click on Table. The following dialog box opens (as shown in Figure 16)

![Table Accessibility Attributes](image.png)

Figure 15 - Image Properties

<table>
<thead>
<tr>
<th>Properties</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td></td>
</tr>
<tr>
<td>Width</td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td></td>
</tr>
<tr>
<td>Src</td>
<td></td>
</tr>
<tr>
<td>Link</td>
<td></td>
</tr>
<tr>
<td>Align</td>
<td></td>
</tr>
<tr>
<td>Border</td>
<td></td>
</tr>
<tr>
<td>V Space</td>
<td></td>
</tr>
<tr>
<td>H Space</td>
<td></td>
</tr>
</tbody>
</table>

\( Rows \) and \( Columns \) are the number of rows and columns to be in the table. \( Table\ width \) defines the width of the table on the page. It can be a percentage of the width of the item that contains the table, (here it is the page) or it can be set in pixels. \( Border\ thickness \) is the width of the border of the table cells in pixels. \( Cell\ padding \) is the space left between the cell border and whatever inside the cell (image, text, etc.). \( Cell\ spacing \) is the space left among cells.

Set the number of rows and columns needed and click on OK.
Linking to other pages

To link to another page, highlight the text that will link to another page. From the properties window (as shown in Figure 17), type the URL in the link field. To have this new page open in a separate window, select _blank from the Target drop down list.

Linking to other files

Similarly, to link to other files, select the text that will be the hyperlink. From the properties window (as shown in Figure 17) type in name and location of the file in the Link field.

To search for a file, click on one of the following icons:
to open the Select File dialog OR

and drag the mouse to the required file in the *Files* tab.

**Link to e-mail**
To link to an e-mail, in the link field in the properties window (Figure 17), type `mailto:` followed by the e-mail. For example, `mailto:myemail@aucegypt.edu`.

You can also link to an email using the *Insert menu, Email Link*, where the dialog in appears (Figure 18).

![Email Link](Figure 18 - Insert Email Link)

**Link to presentations**
The easiest way of inserting a presentation is to first create the presentation and save it as HTML. Next, link to the presentation as if you would link to a normal file.

**Inserting Media in the site**
To insert a video, click on *Insert* and then select *Media*, next select *Plugin*. The following dialog box opens (as shown in Figure 19)
Select the media file (in this example, it is the .rm file) and click on OK. Set the width and the height of the window that will show the media file and click OK.

NOTE: The player has to be installed on the developer machine to show the videos.

Working with templates

Dreamweaver templates can help you create Web pages with a consistent design. They make it easier to maintain your Web site, since you can redesign your site and change hundreds of pages in seconds.

A template is a document you can use to create multiple pages that share the same layout. When you create a template, you can indicate which elements of a page should remain constant (non-editable, or locked) in documents based on that template, and which elements can be changed.

When you modify a template, the locked (non-editable) regions in documents that are based on the template are updated to match the changes in the template.

Dreamweaver saves templates with the file extension .dwt in a folder name Templates in your site’s local root folder. If the Templates directory does not already exist, Dreamweaver creates it when you save a new template.

To save an existing document as a template, click on file and then Save As Template. This launches the following dialog box (Figure 20).
Specify the name of the site and the template name in the Save as field and click on Save.

To insert an editable region, click on Insert > Template Objects > Editable Region. Specify the location and size of this editable region. Save the template again.

To use the template, click on File > New to launch the new documents dialog (as shown previously in Figure 9). This time, select Page from Template from the first column. This will list the list of sites and list of each template within the sites in the next columns. Select the template needed and click on Ok.

This will open a new document using the template previously designed. The new context can be added in the pre-defined editable regions. Other regions which were not editable will be locked in this file. Save this file as an .html file.

If any changes are made to the template, the following dialog box will appear when saving it (as shown in Figure 21)
This will list all the files that are based on this template. To reflect the changes in all the files based on this template, click on Update.

**Uploading the site to a server**

To setup the connection to the server, click on Site then Manage Sites. This will launch a dialog box listing all the sites managed on the installed Dreamweaver. Select the site that you are currently working on and click on Edit (as shown in Figure 22). The edit button launches the site definition dialogs (seen earlier in Figure 1 through Figure 7).

![Manage Sites](image)

**Figure 22. Manage Sites**

Click next to reach the step shown in Figure 6. Change the “How do you connect to your remote server” question and select FTP from the drop down list. This will show a new set of fields (as shown in Figure 23). Fill in the values for the hostname, directory on the server, user name and password as required. (These values are going to be provided by the server administrator). To test that the connection to the server, click on Test Connection. Once you are sure that the connection to the server has been established, click Next to proceed to the end of the dialog boxes.
Figure 23. Set FTP settings

The Local view lists the file on the local machine and the remote view lists the files on the server. To upload files to the server (*put*), first connect to the site by clicking on the connect icon (as shown in Figure 24).

Figure 24. Get and Put

When the connection to the site is on, the icon will change from 📦 to 🔄.

To PUT files to the server, click on the Blue UP arrow 🔄. And to GET files from the server, click on the Green DOWN arrow 📦.

Useful links


http://www.w3schools.com

http://www.freecsstemplates.org/